Email delivery issues
Incident Report for Kisi
Resolved
Our email delivery provider has implemented a fix and is monitoring the results.

Emails are being delivered successfully since 13:52 UTC.
Posted May 27, 2024 - 14:47 UTC
Monitoring
A majority of emails are being delivered as of 13:52 UTC. We will continue to monitor the issue.
Posted May 27, 2024 - 13:55 UTC
Update
We have identified our email delivery service as the cause of this incident. See https://status.mailgun.com/incidents/8bn2px3nyfy4

Currently, a majority of our outgoing emails are affected.
Posted May 27, 2024 - 13:38 UTC
Identified
We are investigating an issue causing email delays for all customers.

The incident started 13:10 UTC, and is ongoing.
Posted May 27, 2024 - 13:32 UTC
This incident affected: Kisi API (Background jobs).