Cisco Meraki Snapshot API Unavailable

Incident Report for Kisi

Resolved

Cisco Meraki Snapshots are working normally again. We have a backlog but it will be cleared in sometime.
Posted Jul 16, 2026 - 04:42 UTC

Monitoring

Cisco Meraki has solved the issue on their end. We will enable snapshots processing on our end and monitor it.

Reference: https://status.meraki.net/incidents/6lb0s9fbny1c
Posted Jul 16, 2026 - 03:38 UTC

Update

Cisco Meraki API endpoint for fetching camera snapshots is not working as expected. We have contacted Cisco Meraki support.
Posted Jul 15, 2026 - 08:36 UTC

Update

We have recovered mostly on all integrations except Cisco Meraki integration. We are working on a fix.
Posted Jul 15, 2026 - 06:27 UTC

Identified

The issue has been identified and we are working on a fix.
Posted Jul 15, 2026 - 02:27 UTC
This incident affected: Kisi Marketplace (ABC Ignite Integration, Cisco Meraki Integration, Glofox Integration, Google Calendar Integration, Google Directory Integration, Microsoft Teams Integration, Mindbody Integration, VORTEX Integration).