Google Cloud Platform has restored service, and all of our affected systems are operating normally again.
Posted Jun 12, 2025 - 20:57 UTC
Investigating
Google Cloud Platform is experiencing an outage. Unlocks are not affected, but there may be delays for event related processing (webhooks, event history, ...).
Posted Jun 12, 2025 - 18:30 UTC
This incident affected: Kisi API (Endpoints, Background jobs).