Email delivery issues
Incident Report for Kisi
Resolved
Fix implemented by our email service provider seems to have fixed the issue. All our outgoing emails have been delivered since 08:30 UTC.
Posted May 31, 2024 - 09:59 UTC
Monitoring
A fix has been implemented by our email delivery service provider and we are monitoring results. As of 08:30 UTC a majority of emails are being delivered.
Posted May 31, 2024 - 09:01 UTC
Identified
An issue is ongoing causing email delays for all customers. We have identified our email delivery service as the cause of this incident. See https://status.mailgun.com/incidents/30w5l1zqcw5r

Currently, a majority of our outgoing emails are affected.
Posted May 31, 2024 - 07:50 UTC
This incident affected: Kisi API (Background jobs).