Email delivery delays

Incident Report for Kisi

Resolved

Our email provider is reporting degraded performance, but we are not seeing any unusual email delivery delays at this point.
Posted Feb 22, 2023 - 10:49 UTC

Update

Our email provider has identified the problem and is implementing a fix.
Posted Feb 21, 2023 - 19:24 UTC

Monitoring

Our email provider is reporting email delivery latency issues.
Up to 5% emails may be delayed by more than one minute.
Posted Feb 21, 2023 - 17:37 UTC
This incident affected: Kisi API (Background jobs).