Email delivery issues

Incident Report for Kisi

Resolved

Email delivery is working again.
Posted Jun 30, 2022 - 13:45 UTC

Update

We are working with our email provider to resolve the issue.
Posted Jun 30, 2022 - 13:23 UTC

Identified

We have an ongoing issues delivering emails. All outgoing emails are affected. We expect it to be resolved shortly.
Posted Jun 30, 2022 - 13:11 UTC