Email delivery issues
Incident Report for Kisi
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 05:30 EDT
Monitoring
Email delivery times are back to normal. We have identified the root cause and we are working on a fix.
Posted Sep 22, 2022 - 05:09 EDT
Investigating
We are investigating an issue causing email delays for all customers.
Posted Sep 22, 2022 - 04:58 EDT
This incident affected: Kisi API (Email Delivery).