Email delivery delays

Incident Report for Kisi

Resolved

This incident has been resolved.
Posted Nov 04, 2022 - 13:43 UTC

Monitoring

Delivery times are back to normal, we are investigating how to avoid these issues in the future.
Posted Nov 04, 2022 - 12:54 UTC

Update

We have allocated additional resources in order to improve email processing times.
Posted Nov 04, 2022 - 12:16 UTC

Identified

We have identified an issue with our email delivery system. Some emails will be delivered late.
Posted Nov 04, 2022 - 12:05 UTC
This incident affected: Kisi API (Background jobs).